<!DOCTYPE html>
<html lang="en" >
  <head>
    <meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>
	APO Group - Africa Newsroom / Press Releases Related to Africa
</title>
<meta name="author" content="APO Group - Africa Newsroom">

<meta name="description" content="Africa Newsroom offers the latest Africa-related news releases & official statements issued by companies, governments, international organizations, NGOs & the UN.">
<meta name="keywords" content="Africa Newsroom, Africa News, Press Release Africa, Press Release, Africa, Press Release Distribution Africa, Press Release Distribution, APO Group, African Press Organization, Public Relations Africa, Marketing Africa">

<!-- Mobile viewport optimized -->
<meta name="viewport" content="width=device-width,initial-scale=1">

<!-- Set a base location for assets -->
<base href="https://itfc.africa-newsroom.com/"/>
<!-- End base -->

<!-- Bootstrap -->
<!-- CSS. No need to specify the media attribute unless specifically targeting a media type, leaving blank implies media=all -->










	
	
	<link rel="stylesheet" type="text/css" href="https://itfc.africa-newsroom.com/source/source_css/713">
<!-- End CSS-->

	<link rel="shortcut icon" href="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/32/32/fit"> 








<script src='https://www.google.com/recaptcha/api.js'></script>

<!-- All JavaScript at the bottom, except for Modernizr. -->
<!--[if lt IE 9]>
	
	
<![endif]-->
<script type="text/javascript">
	pyro                     = { 'lang' : {} };
	var APPPATH_URI          = "/system/cms/";
	var SITE_URL             = "https://itfc.africa-newsroom.com/";
	var BASE_URL             = "https://itfc.africa-newsroom.com/";
	var BASE_URI             = "/";
	var UPLOAD_PATH          = "uploads/default/";
	var DEFAULT_TITLE        = "APO Group - Africa Newsroom";
	pyro.apppath_uri         = "/system/cms/";
	pyro.base_uri            = "/";
	pyro.lang.remove         = "Remove";
	pyro.lang.dialog_message = "Are you sure you want to delete this? It cannot be undone.";
	pyro.csrf_cookie_name    = "default_csrf_cookie_name";
	pyro.http_host           = "africa-newsroom.com";
</script>
<link rel="stylesheet" href="https://itfc.africa-newsroom.com/assets/cache/bcf7f2b7c2c3c8b3cb4306c15a5a7e2c.css" />

<script src="https://itfc.africa-newsroom.com/assets/cache/a38f4a531a3ae441278bb8620a732568.js"></script>

<link rel="canonical" href="https://itfc.africa-newsroom.com/" /><link rel="stylesheet" href="https://itfc.africa-newsroom.com/assets/cache/b370102605a4744ebb49253158381e92.css" />
<script src="https://itfc.africa-newsroom.com/assets/cache/3e7b5ee36b8651db5227bc69ce98605b.js"></script>

<!-- Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-73949312-1', 'auto');
  ga('send', 'pageview');

</script>


<!-- Google Analytics End -->


</head>
  <body class="en">
  <div class="cookie-message">
  <div class="alert alert-info text-center cookie-msg hide">
      <button type="button" class="close close-cookiemsg" data-dismiss="alert" aria-hidden="true">&times;</button>
      We use cookies to improve your experience. By your continued use of this site you accept such use.
  </div>
  </div>
    <div class="container">
            <header class="header row" role="banner">
<div class="col-lg-3 col-md-3 col-sm-5 col-xs-12">
	<div class="hgroup">
  		<h1 id="logo">
                    <a href="https://itfc.africa-newsroom.com/press?lang=en"><img src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/300/120" alt="International Islamic Trade Finance Corporation (ITFC)" style="max-height: 80px;max-width:200px" /></a>
                </h1>
  </div>
</div>
<div class="col-lg-9 col-md-9 col-sm-6 col-xs-12">
    <nav class="clearfix">
        <ul class="top-nav">
                      <li class="first parent">
              <a href="http://africa-newsroom.com/source?lang=en">Press Offices</a>
            </li>
                      <li class="last parent">
              <a href="http://africa-newsroom.com/press-offices?lang=en">Get Your Own Press Office</a>
            </li>
          
                     <li><a href="#" data-toggle="modal" data-target="#modal-login">Log In/Signup</a>
          
          <li>
          <form name="change_lang">
            <select name="change_lang_select" onchange="location.href=change_lang.change_lang_select.options[selectedIndex].value" class="form-control bfh-languages chosen" data-language="en">
              <option value="https://itfc.africa-newsroom.com/?lang=en"  selected >En</option>
              <option value="https://itfc.africa-newsroom.com/?lang=fr" >Fr</option>
              <option value="https://itfc.africa-newsroom.com/?lang=pt" >Pt</option>
              <option value="https://itfc.africa-newsroom.com/?lang=ar" >Ar</option>
            </select>
          </form>
          </li>
        </ul>
    </nav>
    <nav class="navbar" role="navigation">
      <!-- Brand and toggle get grouped for better mobile display -->
      <div class="navbar-header">
        <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
          <span class="sr-only">Toggle navigation</span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <span class="icon-bar"></span>
          <strong>Menu</strong>
        </button>
      </div>
      <!-- Collect the nav links, forms, and other content for toggling -->
      
        <div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
            <ul class="nav navbar-nav">
                            <li class="home first parent"><a href="https://itfc.africa-newsroom.com/?lang=en">Home</a></li>
                            <li class="parent"><a href="https://itfc.africa-newsroom.com/source">About</a></li>
                            <li class="parent"><a href="https://itfc.africa-newsroom.com/source#aboutcontactform">Contact</a></li>
                            <li class="last parent"><a href="http://www.africa-newsroom.com/">Back to Africa Newsroom</a></li>
              
              <!-- <li><a href="https://africa-newsroom.com">Back To Africa NewsRoom</a></li> -->
            </ul>
      </div><!-- /.navbar-collapse -->
    </nav>
</div>
</header>
<!-- /header ends here -->

        <section class="row">
<div class="col-md-12 ">
  <div class="widget press_search ">
		<div class="advance-search clearfix" style="display: none;">
<form action="https://itfc.africa-newsroom.com/press/index" method="post" accept-charset="utf-8" name="press_search" role="form" id="press_search" autocomplete="off">
    <div class="form-group">
          <div class="form-item form-item-search">
                <input type="search" name="keyword" value="" class="form-control" id="keyword" placeholder="Search by keyword"  />
            </div>
            <div class="form-item">
                <select name="press_industry_id[]" id="press_industry_id" class="multiselectfiltering " data-title="Industry"  multiple="multiple">
<option value="201">Advertising</option>
<option value="81">Agriculture</option>
<option value="189">Aviation/Airlines</option>
<option value="213">Banking/Finance</option>
<option value="97">Books</option>
<option value="217">Chemical</option>
<option value="125">Cinema</option>
<option value="221">Computers</option>
<option value="85">Culture/Arts</option>
<option value="205">Defense/Aerospace</option>
<option value="109">Education</option>
<option value="225">Electricity</option>
<option value="121">Entertainment</option>
<option value="117">Environment</option>
<option value="229">Food/Beverages</option>
<option value="133">Health</option>
<option value="137">Infectious Diseases</option>
<option value="277">Infrastructure</option>
<option value="233">Insurance</option>
<option value="237">Internet Technology</option>
<option value="261">Investment</option>
<option value="241">Logistics</option>
<option value="245">Maritime</option>
<option value="149">Mining</option>
<option value="253">Mobile</option>
<option value="209">Motoring</option>
<option value="257">Music</option>
<option value="161">Oil and Gas</option>
<option value="249">Pharmaceutical</option>
<option value="265">Renewable energy</option>
<option value="688">Retail</option>
<option value="792">Rugby</option>
<option value="197">Sport</option>
<option value="173">Telecommunications</option>
<option value="269">Textile</option>
<option value="273">Tobacco</option>
<option value="145">Tourism</option>
<option value="181">Transport</option>
<option value="281">Wood/Forest</option>
</select>
            </div>
            <div class="form-item">
                <select name="press_subject_id[]" id="press_subject_id" class="multiselectfiltering " data-title="Subject" multiple="multiple">
<option value="293">African Development</option>
<option value="289">Animals</option>
<option value="89">Asia</option>
<option value="93">Awards</option>
<option value="912">Basketball</option>
<option value="285">Business</option>
<option value="105">Children</option>
<option value="948">Coronavirus</option>
<option value="113">Economy</option>
<option value="656">Energy</option>
<option value="305">European Government</option>
<option value="129">Events/Media Advisory</option>
<option value="185">Foreign Policy</option>
<option value="309">Handicapped/Disabled</option>
<option value="668">Humanitarian Aid</option>
<option value="193">Justice/Legal issues</option>
<option value="141">Labour market</option>
<option value="157">Not For Profit</option>
<option value="101">Oil/Gas discoveries</option>
<option value="165">Personnel announcements</option>
<option value="169">Religion</option>
<option value="804">Technology</option>
<option value="177">Trade</option>
<option value="297">Urbanism/Cities</option>
<option value="301">Water/Sanitation</option>
<option value="153">Women</option>
</select>
            </div>
            <div class="form-item">
                <select name="press_country_id[]" id="press_country_id" class="multiselectfiltering " data-title="Country" multiple="multiple">
<option value="648">Afghanistan</option>
<option value="652">Africa</option>
<option value="872">Albania</option>
<option value="313">Algeria</option>
<option value="800">Ambazonia</option>
<option value="321">Angola</option>
<option value="740">Argentina</option>
<option value="888">Armenia</option>
<option value="684">Australia</option>
<option value="457">Austria</option>
<option value="700">Bahrain</option>
<option value="744">Belarus</option>
<option value="449">Belgium</option>
<option value="329">Benin</option>
<option value="333">Botswana</option>
<option value="760">Brazil</option>
<option value="764">Brunei Darussalam</option>
<option value="936">Bulgaria</option>
<option value="341">Burkina Faso</option>
<option value="345">Burundi</option>
<option value="732">California</option>
<option value="353">Cameroon</option>
<option value="621">Canada</option>
<option value="361">Cape Verde</option>
<option value="369">Central African Republic</option>
<option value="377">Chad</option>
<option value="944">Chile</option>
<option value="433">China</option>
<option value="385">Comoros</option>
<option value="393">Congo (Republic of the)</option>
<option value="788">Croatia</option>
<option value="900">Croatie</option>
<option value="736">Cuba</option>
<option value="920">Cyprus</option>
<option value="876">Czech Republic</option>
<option value="425">Democratic Republic of Congo</option>
<option value="421">Denmark</option>
<option value="441">Djibouti</option>
<option value="473">Egypt</option>
<option value="489">Equatorial Guinea</option>
<option value="501">Eritrea</option>
<option value="932">Estonia</option>
<option value="505">Ethiopia</option>
<option value="752">Finland</option>
<option value="497">France</option>
<option value="521">Gabon</option>
<option value="533">Gambia</option>
<option value="469">Germany</option>
<option value="545">Ghana</option>
<option value="728">Greece</option>
<option value="561">Guinea</option>
<option value="577">Guinea-Bissau</option>
<option value="928">Guyana</option>
<option value="896">Hong Kong</option>
<option value="784">Hungary</option>
<option value="756">Illinois</option>
<option value="409">India</option>
<option value="880">Iraq</option>
<option value="660">Ireland</option>
<option value="401">Islamic Republic of Iran</option>
<option value="397">Israel</option>
<option value="389">Italy</option>
<option value="593">Ivory Coast</option>
<option value="381">Japan</option>
<option value="716">Jordan</option>
<option value="601">Kenya</option>
<option value="664">Kingdom of Saudi Arabia</option>
<option value="724">Kuwait</option>
<option value="884">Latvia</option>
<option value="720">Lebanon</option>
<option value="609">Lesotho</option>
<option value="613">Liberia</option>
<option value="605">Libya</option>
<option value="856">Lithuania</option>
<option value="676">Luxembourg</option>
<option value="597">Madagascar</option>
<option value="585">Malawi</option>
<option value="772">Malaysia</option>
<option value="864">Maldives</option>
<option value="573">Mali</option>
<option value="680">Malta</option>
<option value="557">Mauritania</option>
<option value="537">Mauritius</option>
<option value="708">Middle East</option>
<option value="712">Monaco</option>
<option value="517">Morocco</option>
<option value="481">Mozambique</option>
<option value="465">Namibia</option>
<option value="644">Nepal</option>
<option value="373">Netherlands</option>
<option value="692">New Zealand</option>
<option value="405">Niger</option>
<option value="417">Nigeria</option>
<option value="820">NORTH SUDAN</option>
<option value="365">Norway</option>
<option value="812">OMAN</option>
<option value="844">Oman</option>
<option value="892">Pakistan</option>
<option value="768">People's Republic of Bangladesh</option>
<option value="860">Philippines</option>
<option value="840">Poland</option>
<option value="357">Portugal</option>
<option value="816">QATAR</option>
<option value="796">Republic of Korea</option>
<option value="780">Romania</option>
<option value="337">Russia</option>
<option value="429">Rwanda</option>
<option value="437">Sao Tome and Principe</option>
<option value="453">Senegal</option>
<option value="461">Seychelles</option>
<option value="477">Sierra Leone</option>
<option value="349">Singapore</option>
<option value="904">Slovenia</option>
<option value="493">Somalia</option>
<option value="776">Somaliland</option>
<option value="513">South Africa</option>
<option value="940">South America</option>
<option value="529">South Sudan</option>
<option value="413">Spain</option>
<option value="848">Sri Lanka</option>
<option value="553">Sudan</option>
<option value="924">Suriname</option>
<option value="581">Swaziland</option>
<option value="824">Sweden</option>
<option value="828">SWEDEN</option>
<option value="832">SWEDEN</option>
<option value="325">Switzerland</option>
<option value="868">Tajikistan</option>
<option value="589">Tanzania</option>
<option value="836">Thailand</option>
<option value="748">The People's Republic of China</option>
<option value="569">Togo</option>
<option value="565">Tunisia</option>
<option value="317">Turkey</option>
<option value="916">Turkmenistan</option>
<option value="549">Uganda</option>
<option value="852">Ukraine</option>
<option value="628">United Arab Emirates</option>
<option value="485">United Kingdom</option>
<option value="509">United States of America</option>
<option value="908">Uzbekistan</option>
<option value="617">Vatican</option>
<option value="808">Yemen</option>
<option value="541">Zambia</option>
<option value="525">Zimbabwe</option>
</select>
            </div>
            <div class="form-item form-item-startdate">               
                <input type="text" name="start_date" value="" id="start-date" class="form-control dateNtime" placeholder="From" />
            </div>
            <div class="form-item form-itme-enddate">               
                <input type="text" name="end_date" value="" id="end-date" class="form-control dateNtime" placeholder="To" />
            </div>
            <div class="form-item form-item-radio" data-s="radio" >
                <label for="pressrelease" class="radiotext">
                    <input type="radio" name="press_type" id="pressrelease" value="press"  checked="checked" >
                    Press release
                </label>
                <label for="multimedia" class="radiotext">
                    <input type="radio" name="press_type" id="multimedia" value="media"  >
                    Multimedia content
                </label>
              <button type="submit" class="btn btn-default pull-right"></button>
              </div>
                <div class="form-group checkbox media_types">

                    <div class="form-item form-item-checkbox" style="padding:0;">
                      Filter by: 
                    </div>
                    <div class="form-item form-item-checkbox">
                        <input id="checkbox-all" class="mediatype-checkall" type="checkbox" checked="checked" data-value="yes"> 
                        <label for="checkbox-all">All</label>
                    </div>
                                        <div class="form-item form-item-checkbox">
                        <input id="checkbox-Video" class="mediatype-check" name="media_type[v]" value="v" type="checkbox" > 
                        <label for="checkbox-Video">Video</label>
                    </div>
                                        <div class="form-item form-item-checkbox">
                        <input id="checkbox-Images" class="mediatype-check" name="media_type[i]" value="i" type="checkbox" > 
                        <label for="checkbox-Images">Images</label>
                    </div>
                                        <div class="form-item form-item-checkbox">
                        <input id="checkbox-Documents" class="mediatype-check" name="media_type[d]" value="d" type="checkbox" > 
                        <label for="checkbox-Documents">Documents</label>
                    </div>
                                    </div>
          </div>
    </form>
</div>
</div>


</div>
</section>

        <div class="clearfix col-sm-12">
        </div>
    
<div class="clearfix">
    <div class="site-content">
      <div class="main-container page-media-content">
          <div id="infinite-scroll">
  
<article class="row " data-pressid="107166" data-pressPublished="2020-03-23T12:16:58Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(2)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>International Islamic Trade Finance Corporation recognized as Best Islamic Financier at the International Trade Finance Global (TFG) Trade Awards 2020 (1)</li>
                                        <li><i class="fa fa-caret-right"></i>International Islamic Trade Finance Corporation recognized as Best Islamic Financier at the International Trade Finance Global (TFG) Trade Awards 2020 (2)</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(3)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/107166/http%3A%7D%7Dhttps%3A%7D%7Dwww.itfc-idb.org%7Den/website" target="_blank" rel="nofollow">
                    International Islamic Trade Fi...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/107166/http%3A%7D%7Dwww.tradefinanceglobal.com%7D/website" target="_blank" rel="nofollow">
                    Trade Finance Global (TFG)                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/107166/http%3A%7D%7Dhttps%3A%7D%7Dwww.baft.org%7D/website" target="_blank" rel="nofollow">
                    BAFT                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(5)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2020-03-23T12:16:58Z">
                    Mar 23, 2020                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020?lang=en" title="International Islamic Trade Finance Corporation recognized as Best Islamic Financier at the International Trade Finance Global (TFG) Trade Awards 2020">International Islamic Trade Finance Corporation recognized as Best Islamic Financier at the International Trade Finance Global (TFG) Trade Awards 2020</a></h2>
                    <p class="home-subheading"><strong>The winners were selected by an independent steering committee of industry experts from around the world</strong></p>
        
        
        
        <p>The International Islamic Trade Finance Corporation (ITFC) (www.ITFC-IDB.org), a member of the Islamic Development Bank (IsDB) Group, has been named &lsquo;Best Islamic Financier&rsquo; by the trade finance platform, Trade Finance Global (www.TradeFinanceGlobal.com), in cooperation with BAFT (www.BAFT.org).



The international work carried out by banks, financial institutions and technology vendors to&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="107166" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://bit.ly/2J4XxBs
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="107166" title="twitter" href="https://twitter.com/intent/tweet?text=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020+https%3A%2F%2Fbit.ly%2F2J4XxBs%0A+%23agriculture+%23bankingfinance+%23business+%23education+%23energy+%23environment+%23technology">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="107166" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://bit.ly/2J4XxBs
&amp;title=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="107166" title="google" href="https://plus.google.com/share?url=https://bit.ly/2J4XxBs
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="107166" title="tumblr" href="https://www.tumblr.com/share/link?url=https://bit.ly/2J4XxBs
&amp;name=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="107166" title="reddit" href="http://reddit.com/submit?url=https://bit.ly/2J4XxBs
&amp;title=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="107166" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/200/150&amp;url=https://bit.ly/2J4XxBs
&amp;description=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="107166" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=https://bit.ly/2J4XxBs
&amp;title=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/107166"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/agriculture">Agriculture</a></li>
                                                                                <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                <li><a href="https://itfc.africa-newsroom.com/press/tag/education">Education</a></li>
                                                                                <li><a href="https://itfc.africa-newsroom.com/press/tag/energy">Energy</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/environment">Environment</a></li>
                                                                                                                                                              <li><a href="https://itfc.africa-newsroom.com/press/tag/technology">Technology</a></li>
                                                                                        </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="106586" data-pressPublished="2020-03-16T10:13:52Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(1)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>Eng. Hani Salem Sonbol, CEO, ITFC</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(1)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/106586/http%3A%7D%7Dhttps%3A%7D%7Dwww.itfc-idb.org%7Den/website" target="_blank" rel="nofollow">
                    International Islamic Trade Fi...                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(2)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2020-03-16T10:13:52Z">
                    Mar 16, 2020                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en" title="International Islamic Trade Finance Corporation (ITFC) Ranks 2nd Globally and as well in Europe, Middle East and Africa (EMEA) as Islamic Finance Bookrunner and Mandated Lead Arranger - Bloomberg Syndicated Loans League Tables 2019">International Islamic Trade Finance Corporation (ITFC) Ranks 2nd Globally and as well in Europe, Middle East and Africa (EMEA) as Islamic Finance Bookrunner and Mandated Lead Arranger - Bloomberg Syndicated Loans League Tables 2019</a></h2>
                    <p class="home-subheading"><strong>The League Tables, showed that the ITFC provided financing worth in excess of US$2 billion as Bookrunner and Mandated Lead Arranger in 2019</strong></p>
        
        
        
        <p>The International Islamic Trade Finance Corporation (ITFC) (www.ITFC-IDB.org), member of the Islamic Development Bank (IsDB) Group, ranked 2nd Globally and as well in Europe, Middle East and Africa&rsquo;s (EMEA) Islamic Finance listings of the Bloomberg Syndicated Loans League Tables 2019 for the largest Bookrunner and Mandated Lead Arranger.



The League&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="106586" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/39PWYqO
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="106586" title="twitter" href="https://twitter.com/intent/tweet?text=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019+http%3A%2F%2Fbit.ly%2F39PWYqO%0A+%23agriculture+%23bankingfinance+%23business+%23health">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="106586" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="106586" title="google" href="https://plus.google.com/share?url=http://bit.ly/39PWYqO
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="106586" title="tumblr" href="https://www.tumblr.com/share/link?url=http://bit.ly/39PWYqO
&amp;name=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="106586" title="reddit" href="http://reddit.com/submit?url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="106586" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/200/150&amp;url=http://bit.ly/39PWYqO
&amp;description=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="106586" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/106586"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                  <li><a href="https://itfc.africa-newsroom.com/press/tag/agriculture">Agriculture</a></li>
                                                                                <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                                                                                                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/health">Health</a></li>
                                                                                                                                                                                                </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="100139" data-pressPublished="2019-12-09T04:45:37Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-partners-forum-highlights-immense-strength-of-islamic-finance-globally?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(1)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO Eng. Hani Salem Sonbol alongside Prof Benedict Oramah, President Afreximbank, HE Muhammad Hammad Azhar, Minister for Economic Affairs, Government of Pakistan and H.E. Dr. Bandar Hajjar, President, Islamic Development Bank Group at the ITFC Partners Forum in Jeddah, KSA</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-partners-forum-highlights-immense-strength-of-islamic-finance-globally?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(2)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/100139/http%3A%7D%7Dhttps%3A%7D%7Dwww.itfc-idb.org%7Den/website" target="_blank" rel="nofollow">
                    International Islamic Trade an...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/100139/http%3A%7D%7Dhttps%3A%7D%7Ditfcpartnersforum.org/website" target="_blank" rel="nofollow">
                    Forum                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-partners-forum-highlights-immense-strength-of-islamic-finance-globally?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(3)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2019-12-09T04:45:37Z">
                    Dec 09, 2019                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-partners-forum-highlights-immense-strength-of-islamic-finance-globally?lang=en" title="International Islamic Trade Finance Corporation (ITFC) Partners Forum Highlights Immense Strength of Islamic Finance Globally">International Islamic Trade Finance Corporation (ITFC) Partners Forum Highlights Immense Strength of Islamic Finance Globally</a></h2>
                    <p class="home-subheading"><strong>ITFC was joined by a host of local, regional and international finance institutions alongside official delegates from Pakistan and other member countries</strong></p>
        
        
        
        <p>The International Islamic Trade Finance Corporation (ITFC) (www.ITFC-IDB.org), a member of the Islamic Development Bank Group (IsDB), successfully concluded its Partners Forum 2019: Investing for Impact, which was held on the 5th December in Jeddah, Kingdom of Saudi Arabia.



Hosted at the Ritz Carlton Hotel, under the auspices of H.E&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-partners-forum-highlights-immense-strength-of-islamic-finance-globally?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="100139" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2Ystpqi
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="100139" title="twitter" href="https://twitter.com/intent/tweet?text=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+Forum+Highlights+Immense+Strength+of+Islamic+Finance+Globally+http%3A%2F%2Fbit.ly%2F2Ystpqi%0A+%23bankingfinance+%23business">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="100139" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://bit.ly/2Ystpqi
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+Forum+Highlights+Immense+Strength+of+Islamic+Finance+Globally&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="100139" title="google" href="https://plus.google.com/share?url=http://bit.ly/2Ystpqi
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="100139" title="tumblr" href="https://www.tumblr.com/share/link?url=http://bit.ly/2Ystpqi
&amp;name=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+Forum+Highlights+Immense+Strength+of+Islamic+Finance+Globally"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="100139" title="reddit" href="http://reddit.com/submit?url=http://bit.ly/2Ystpqi
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+Forum+Highlights+Immense+Strength+of+Islamic+Finance+Globally"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="100139" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/200/150&amp;url=http://bit.ly/2Ystpqi
&amp;description=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+Forum+Highlights+Immense+Strength+of+Islamic+Finance+Globally"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="100139" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=http://bit.ly/2Ystpqi
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+Forum+Highlights+Immense+Strength+of+Islamic+Finance+Globally"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/100139"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-itfc-partners-forum-highlights-immense-strength-of-islamic-finance-globally');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                  <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                                                                                                                                                          </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="96558" data-pressPublished="2019-10-21T12:13:59Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/fbad49dd09be89e/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/the-international-islamic-trade-finance-corporation-itfc-and-ocp-africa-unite-for-the-strategic-financing-innovation-and-capacity-building-of-agriculture-in-africa?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(1)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO Eng. Hani Salem Sonbol and CEO OCP Africa Mr. Karim Lotfi Senhadji sign MOU to improve agriculture in Africa</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/the-international-islamic-trade-finance-corporation-itfc-and-ocp-africa-unite-for-the-strategic-financing-innovation-and-capacity-building-of-agriculture-in-africa?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(2)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/96558/http%3A%7D%7Dwww.itfc-idb.org%7Den/website" target="_blank" rel="nofollow">
                    International Islamic Trade an...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/96558/http%3A%7D%7Dwww.ocpafrica.com%7D/website" target="_blank" rel="nofollow">
                    OCP Africa                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/the-international-islamic-trade-finance-corporation-itfc-and-ocp-africa-unite-for-the-strategic-financing-innovation-and-capacity-building-of-agriculture-in-africa?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(3)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2019-10-21T12:13:59Z">
                    Oct 21, 2019                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/the-international-islamic-trade-finance-corporation-itfc-and-ocp-africa-unite-for-the-strategic-financing-innovation-and-capacity-building-of-agriculture-in-africa?lang=en" title="The International Islamic Trade Finance Corporation (ITFC) and OCP Africa unite for the strategic financing, innovation, and capacity building of agriculture in Africa">The International Islamic Trade Finance Corporation (ITFC) and OCP Africa unite for the strategic financing, innovation, and capacity building of agriculture in Africa</a></h2>
                    <p class="home-subheading"><strong>ITFC and OCP Africa will jointly introduce a new “OCP School lab” campaign in Senegal in November 2019</strong></p>
        
        
        
        <p>The International Islamic Trade Finance Corporation, (ITFC, International Islamic Trade Finance Corporation) (ITFC-IDB.org), a member of the Islamic Development Bank (IsDB) Group, and OCP Africa ) (OCPAfrica.com), a subsidiary of OCP SA, have signed a Memorandum of Understanding (MoU) that will cater towards strategic funding, innovation and capacity building measures&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/the-international-islamic-trade-finance-corporation-itfc-and-ocp-africa-unite-for-the-strategic-financing-innovation-and-capacity-building-of-agriculture-in-africa?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="96558" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2BwRNfO
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="96558" title="twitter" href="https://twitter.com/intent/tweet?text=The+International+Islamic+Trade+Finance+Corporation+%28ITFC%29+and+OCP+Africa+unite+for+the+strategic+financing%2C+innovation%2C+and+capacity+building+of+agriculture+in+Africa+http%3A%2F%2Fbit.ly%2F2BwRNfO%0A+%23agriculture+%23bankingfinance+%23business+%23education+%23environment+%23technology">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="96558" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://bit.ly/2BwRNfO
&amp;title=The+International+Islamic+Trade+Finance+Corporation+%28ITFC%29+and+OCP+Africa+unite+for+the+strategic+financing%2C+innovation%2C+and+capacity+building+of+agriculture+in+Africa&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="96558" title="google" href="https://plus.google.com/share?url=http://bit.ly/2BwRNfO
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="96558" title="tumblr" href="https://www.tumblr.com/share/link?url=http://bit.ly/2BwRNfO
&amp;name=The+International+Islamic+Trade+Finance+Corporation+%28ITFC%29+and+OCP+Africa+unite+for+the+strategic+financing%2C+innovation%2C+and+capacity+building+of+agriculture+in+Africa"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="96558" title="reddit" href="http://reddit.com/submit?url=http://bit.ly/2BwRNfO
&amp;title=The+International+Islamic+Trade+Finance+Corporation+%28ITFC%29+and+OCP+Africa+unite+for+the+strategic+financing%2C+innovation%2C+and+capacity+building+of+agriculture+in+Africa"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="96558" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/fbad49dd09be89e/200/150&amp;url=http://bit.ly/2BwRNfO
&amp;description=The+International+Islamic+Trade+Finance+Corporation+%28ITFC%29+and+OCP+Africa+unite+for+the+strategic+financing%2C+innovation%2C+and+capacity+building+of+agriculture+in+Africa"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="96558" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=http://bit.ly/2BwRNfO
&amp;title=The+International+Islamic+Trade+Finance+Corporation+%28ITFC%29+and+OCP+Africa+unite+for+the+strategic+financing%2C+innovation%2C+and+capacity+building+of+agriculture+in+Africa"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/96558"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/the-international-islamic-trade-finance-corporation-itfc-and-ocp-africa-unite-for-the-strategic-financing-innovation-and-capacity-building-of-agriculture-in-africa');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/agriculture">Agriculture</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                <li><a href="https://itfc.africa-newsroom.com/press/tag/education">Education</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/environment">Environment</a></li>
                                                                                                                                                                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/technology">Technology</a></li>
                                                                                        </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="85096" data-pressPublished="2019-05-02T07:30:08Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-partners-with-ie-school-of-global-and-public-affairs-and-international-trade-centre-to-launch-pioneering-trade-masters-degree?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(1)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>International Islamic Trade Finance Corporation (ITFC) Partners with IE School of Global & Public Affairs and International Trade Centre to Launch Pioneering Trade Master’s Degree</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-partners-with-ie-school-of-global-and-public-affairs-and-international-trade-centre-to-launch-pioneering-trade-masters-degree?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(5)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/85096/http%3A%7D%7Dwww.ITFC-idb.org/website" target="_blank" rel="nofollow">
                    International Islamic Trade Fi...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/85096/http%3A%7D%7Dhttps%3A%7D%7Dbit.ly%7D2H0vCm5/website" target="_blank" rel="nofollow">
                    IE School of Global and Public...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/85096/http%3A%7D%7Dwww.intracen.org/website" target="_blank" rel="nofollow">
                    International Trade Centre (IT...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/85096/http%3A%7D%7Dhttps%3A%7D%7Dbit.ly%7D2LjDSlh/website" target="_blank" rel="nofollow">
                    Manuel Muniz                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/85096/http%3A%7D%7Dhttps%3A%7D%7Dbit.ly%7D2DIGoeu/website" target="_blank" rel="nofollow">
                    Executive Master in Internatio...                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-partners-with-ie-school-of-global-and-public-affairs-and-international-trade-centre-to-launch-pioneering-trade-masters-degree?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(6)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2019-05-02T07:30:08Z">
                    May 02, 2019                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-partners-with-ie-school-of-global-and-public-affairs-and-international-trade-centre-to-launch-pioneering-trade-masters-degree?lang=en" title="International Islamic Trade Finance Corporation (ITFC) Partners with IE School of Global & Public Affairs and International Trade Centre to Launch Pioneering Trade Master’s Degree">International Islamic Trade Finance Corporation (ITFC) Partners with IE School of Global & Public Affairs and International Trade Centre to Launch Pioneering Trade Master’s Degree</a></h2>
                    <p class="home-subheading"><strong>The program which focuses on trade, trade finance and trade development, is the first of its kind to be initiated by a multilateral financial trade institution</strong></p>
        
        
        
        <p>The International Islamic Trade Finance Corporation (ITFC) (www.ITFC-idb.org), in collaboration with the IE School of Global and Public Affairs (IE) (https://bit.ly/2H0vCm5) and International Trade Centre (ITC) (www.intracen.org) celebrated the launch of the groundbreaking Executive Master in Internationalization and Trade in Spain. Held at the IE School campus in Madrid, the&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-partners-with-ie-school-of-global-and-public-affairs-and-international-trade-centre-to-launch-pioneering-trade-masters-degree?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="85096" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2VIVZEU
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="85096" title="twitter" href="https://twitter.com/intent/tweet?text=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+with+IE+School+of+Global+%26+Public+Affairs+and+International+Trade+Centre+to+Launch+Pioneering+Trade+Master%E2%80%99s+Degree+http%3A%2F%2Fbit.ly%2F2VIVZEU%0A+%23bankingfinance+%23business+%23technology">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="85096" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://bit.ly/2VIVZEU
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+with+IE+School+of+Global+%26+Public+Affairs+and+International+Trade+Centre+to+Launch+Pioneering+Trade+Master%E2%80%99s+Degree&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="85096" title="google" href="https://plus.google.com/share?url=http://bit.ly/2VIVZEU
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="85096" title="tumblr" href="https://www.tumblr.com/share/link?url=http://bit.ly/2VIVZEU
&amp;name=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+with+IE+School+of+Global+%26+Public+Affairs+and+International+Trade+Centre+to+Launch+Pioneering+Trade+Master%E2%80%99s+Degree"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="85096" title="reddit" href="http://reddit.com/submit?url=http://bit.ly/2VIVZEU
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+with+IE+School+of+Global+%26+Public+Affairs+and+International+Trade+Centre+to+Launch+Pioneering+Trade+Master%E2%80%99s+Degree"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="85096" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150&amp;url=http://bit.ly/2VIVZEU
&amp;description=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+with+IE+School+of+Global+%26+Public+Affairs+and+International+Trade+Centre+to+Launch+Pioneering+Trade+Master%E2%80%99s+Degree"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="85096" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=http://bit.ly/2VIVZEU
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Partners+with+IE+School+of+Global+%26+Public+Affairs+and+International+Trade+Centre+to+Launch+Pioneering+Trade+Master%E2%80%99s+Degree"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/85096"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-itfc-partners-with-ie-school-of-global-and-public-affairs-and-international-trade-centre-to-launch-pioneering-trade-masters-degree');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                  <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                                          <li><a href="https://itfc.africa-newsroom.com/press/tag/technology">Technology</a></li>
                                                              </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="84650" data-pressPublished="2019-04-23T09:11:36Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-signs-six-highlevel-trade-agreements-over-uu11bn?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(7)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>Eng. Hani Salem Sonbol CEO ITFC</li>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO Eng. Hani Salem Sonbol and Afreximbank President and Chairman Dr. Benedict Oramah</li>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO Eng. Hani Salem Sonbol and Deputy Minister of Finance of the Kyrgyz Republic Mr. Baigonchokov Mirlanbek Konushbekovich</li>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO Eng. Hani Salem Sonbol and H.E. Aa╠âchatou Boulama KanC╠º, Minister of Planning of Niger and IsDB Governor</li>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO, Eng Hani Salem Sonbol, and HE. Dr. Boubou Cisse, Minister of Economy & Finance, Mali and IsDB Governor</li>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO, Eng. Hani Salem Sonbol and Triqui Zouhair, Secretary General, AMDIE on behalf of Hicham Boudraa, Managing Director, AMDIE</li>
                                        <li><i class="fa fa-caret-right"></i>ITFC CEO, Eng. Hani Salem Sonbol and Mr. Gillmore Hoefdraad, Minister of Finance of Suriname & IsDB Governor</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-signs-six-highlevel-trade-agreements-over-uu11bn?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(1)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/84650/http%3A%7D%7Dwww.ITFC-IDB.org%7Den/website" target="_blank" rel="nofollow">
                    The Islamic Trade Finance Corp...                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-signs-six-highlevel-trade-agreements-over-uu11bn?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(8)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2019-04-23T09:11:36Z">
                    Apr 23, 2019                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-signs-six-highlevel-trade-agreements-over-uu11bn?lang=en" title="International Islamic Trade Finance Corporation signs Six High-Level Trade Agreements Over UU$1.1BN">International Islamic Trade Finance Corporation signs Six High-Level Trade Agreements Over UU$1.1BN</a></h2>
                    <p class="home-subheading"><strong>Major Framework Agreements and Trade Solutions Initiatives in Q2 for Export Growth and Trade Financing in Member Countries of the Organisation of Islamic Cooperation (OIC)</strong></p>
        
        
        
        <p>The International Islamic Trade Finance Corporation (ITFC) (http://www.ITFC-IDB.org/en), member of the Islamic Development Bank (IsDB) Group, has signed six major Trade Financing and Development Agreements worth in excess of US$1.1 Billion with Organisation of Islamic Cooperation (OIC) member countries including the Commonwealth of Independent States (CIS), MENA, South America and&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-signs-six-highlevel-trade-agreements-over-uu11bn?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="84650" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/2Lbyu3F"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="84650" title="twitter" href="https://twitter.com/intent/tweet?text=International+Islamic+Trade+Finance+Corporation+signs+Six+High-Level+Trade+Agreements+Over+UU%241.1BN+http%3A%2F%2Fbit.ly%2F2Lbyu3F+%23bankingfinance+%23business">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="84650" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://bit.ly/2Lbyu3F&amp;title=International+Islamic+Trade+Finance+Corporation+signs+Six+High-Level+Trade+Agreements+Over+UU%241.1BN&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="84650" title="google" href="https://plus.google.com/share?url=http://bit.ly/2Lbyu3F"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="84650" title="tumblr" href="https://www.tumblr.com/share/link?url=http://bit.ly/2Lbyu3F&amp;name=International+Islamic+Trade+Finance+Corporation+signs+Six+High-Level+Trade+Agreements+Over+UU%241.1BN"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="84650" title="reddit" href="http://reddit.com/submit?url=http://bit.ly/2Lbyu3F&amp;title=International+Islamic+Trade+Finance+Corporation+signs+Six+High-Level+Trade+Agreements+Over+UU%241.1BN"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="84650" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150&amp;url=http://bit.ly/2Lbyu3F&amp;description=International+Islamic+Trade+Finance+Corporation+signs+Six+High-Level+Trade+Agreements+Over+UU%241.1BN"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="84650" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=http://bit.ly/2Lbyu3F&amp;title=International+Islamic+Trade+Finance+Corporation+signs+Six+High-Level+Trade+Agreements+Over+UU%241.1BN"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/84650"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-signs-six-highlevel-trade-agreements-over-uu11bn');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                                                                                                                                                                                    </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="72326" data-pressPublished="2018-10-05T17:21:23Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-announces-major-trade-initiatives-at-2018-rebranding-africa-forum?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(3)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>International Islamic Trade Finance Corporation (ITFC) announces major trade initiatives at 2018 Rebranding Africa Forum (1)</li>
                                        <li><i class="fa fa-caret-right"></i>International Islamic Trade Finance Corporation (ITFC) announces major trade initiatives at 2018 Rebranding Africa Forum (2)</li>
                                        <li><i class="fa fa-caret-right"></i>International Islamic Trade Finance Corporation (ITFC) announces major trade initiatives at 2018 Rebranding Africa Forum (3)</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-announces-major-trade-initiatives-at-2018-rebranding-africa-forum?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(3)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/72326/http%3A%7D%7Dwww.ITFC-IDB.org/website" target="_blank" rel="nofollow">
                    International Islamic Trade Fi...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/72326/http%3A%7D%7Dhttps%3A%7D%7Dwe.tl%7Dt-jPjr2nxOwj/website" target="_blank" rel="nofollow">
                    ITFC Press Material                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/72326/http%3A%7D%7Dwww.Coris-Bank.com/website" target="_blank" rel="nofollow">
                    Coris Bank International (CBI ...                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/international-islamic-trade-finance-corporation-itfc-announces-major-trade-initiatives-at-2018-rebranding-africa-forum?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(6)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2018-10-05T17:21:23Z">
                    Oct 05, 2018                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-announces-major-trade-initiatives-at-2018-rebranding-africa-forum?lang=en" title="International Islamic Trade Finance Corporation (ITFC) announces major trade initiatives at 2018 Rebranding Africa Forum">International Islamic Trade Finance Corporation (ITFC) announces major trade initiatives at 2018 Rebranding Africa Forum</a></h2>
                    <p class="home-subheading"><strong>The first announcement was for a US$1.5 Billion Framework Agreement between the Government of Burkina Faso and International Islamic Trade Finance Corporation (ITFC)</strong></p>
        
        
        
        <p>ITFC&nbsp;(www.ITFC-IDB.org) signs US$ 1.5 billion Framework Agreement with the Government of Burkina Faso; West Africa SMEs Program launched to aid financial access for SMEs.



ITFC Press Material : https://we.tl/t-jPjr2nxOwj

The International Islamic Trade Finance Corporation (ITFC), member of the Islamic Development Bank (IsDB) Group, has announced several major initiatives during&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-announces-major-trade-initiatives-at-2018-rebranding-africa-forum?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="72326" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://goo.gl/V5X9AX"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="72326" title="twitter" href="https://twitter.com/intent/tweet?text=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+announces+major+trade+initiatives+at+2018+Rebranding+Africa+Forum+https%3A%2F%2Fgoo.gl%2FV5X9AX+%23bankingfinance+%23business">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="72326" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://goo.gl/V5X9AX&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+announces+major+trade+initiatives+at+2018+Rebranding+Africa+Forum&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="72326" title="google" href="https://plus.google.com/share?url=https://goo.gl/V5X9AX"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="72326" title="tumblr" href="https://www.tumblr.com/share/link?url=https://goo.gl/V5X9AX&amp;name=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+announces+major+trade+initiatives+at+2018+Rebranding+Africa+Forum"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="72326" title="reddit" href="http://reddit.com/submit?url=https://goo.gl/V5X9AX&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+announces+major+trade+initiatives+at+2018+Rebranding+Africa+Forum"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="72326" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150&amp;url=https://goo.gl/V5X9AX&amp;description=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+announces+major+trade+initiatives+at+2018+Rebranding+Africa+Forum"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="72326" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=https://goo.gl/V5X9AX&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+announces+major+trade+initiatives+at+2018+Rebranding+Africa+Forum"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/72326"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-itfc-announces-major-trade-initiatives-at-2018-rebranding-africa-forum');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                                                                          <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                                                                                                                                                                                                                                                                  </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="70778" data-pressPublished="2018-09-10T07:00:50Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/itfc-to-implement-us-3-billion-framework-agreements-through-two-new-financing-agreements-to-support-egypts-main-sectors?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(2)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>(L-R) Eng. Hani Salem Sonbol, CEO ITFC - Dr. Sahar Nasr, Minister of Investment and International Trade - Eng. Tarek El Molla, Minister of Petroleum & Mineral Resources - Eng. Abed Ezz El Regal, Chief Executive Officer EGPC</li>
                                        <li><i class="fa fa-caret-right"></i>(L-R) (L-R) Eng. Hani Salem Sonbol, CEO ITFC - Dr. Sahar Nasr, Minister of Investment and International Trade - Dr. Aly Meselhy Minister of Supply and Internal Trade - Mr. Ahmed Yousef, Deputy Chairman of the Commodity Supply Authority</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/itfc-to-implement-us-3-billion-framework-agreements-through-two-new-financing-agreements-to-support-egypts-main-sectors?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(1)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/70778/http%3A%7D%7Dwww.ITFC-IDB.org/website" target="_blank" rel="nofollow">
                    International Islamic Trade Fi...                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/itfc-to-implement-us-3-billion-framework-agreements-through-two-new-financing-agreements-to-support-egypts-main-sectors?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(3)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2018-09-10T07:00:50Z">
                    Sep 10, 2018                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/itfc-to-implement-us-3-billion-framework-agreements-through-two-new-financing-agreements-to-support-egypts-main-sectors?lang=en" title="ITFC to Implement U.S. $3 Billion Framework Agreements through two new Financing Agreements to Support Egypt’s Main Sectors">ITFC to Implement U.S. $3 Billion Framework Agreements through two new Financing Agreements to Support Egypt’s Main Sectors</a></h2>
                    <p class="home-subheading"><strong>ITFC has signed five framework agreements with the Government of Egypt represented by the Ministry of Investment & International Cooperation totaling U.S. $ 9.2 billion</strong></p>
        
        
        
        <p>The International Islamic Trade Finance Corporation (ITFC) (www.ITFC-IDB.org) announced the signing of two new Agreements between ITFC &amp; the Government of the Arab Republic of Egypt represented by the Egyptian General Petroleum Corporation (EGPC) and the General Authority for Supply Commodities (GASC) initiating the utilization of the 5th Framework agreement.&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/itfc-to-implement-us-3-billion-framework-agreements-through-two-new-financing-agreements-to-support-egypts-main-sectors?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="70778" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://goo.gl/LDHYNo"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="70778" title="twitter" href="https://twitter.com/intent/tweet?text=ITFC+to+Implement+U.S.+%243+Billion+Framework+Agreements+through+two+new+Financing+Agreements+to+Support+Egypt%E2%80%99s+Main+Sectors+https%3A%2F%2Fgoo.gl%2FLDHYNo+%23agriculture+%23bankingfinance+%23business">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="70778" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://goo.gl/LDHYNo&amp;title=ITFC+to+Implement+U.S.+%243+Billion+Framework+Agreements+through+two+new+Financing+Agreements+to+Support+Egypt%E2%80%99s+Main+Sectors&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="70778" title="google" href="https://plus.google.com/share?url=https://goo.gl/LDHYNo"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="70778" title="tumblr" href="https://www.tumblr.com/share/link?url=https://goo.gl/LDHYNo&amp;name=ITFC+to+Implement+U.S.+%243+Billion+Framework+Agreements+through+two+new+Financing+Agreements+to+Support+Egypt%E2%80%99s+Main+Sectors"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="70778" title="reddit" href="http://reddit.com/submit?url=https://goo.gl/LDHYNo&amp;title=ITFC+to+Implement+U.S.+%243+Billion+Framework+Agreements+through+two+new+Financing+Agreements+to+Support+Egypt%E2%80%99s+Main+Sectors"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="70778" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150&amp;url=https://goo.gl/LDHYNo&amp;description=ITFC+to+Implement+U.S.+%243+Billion+Framework+Agreements+through+two+new+Financing+Agreements+to+Support+Egypt%E2%80%99s+Main+Sectors"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="70778" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=https://goo.gl/LDHYNo&amp;title=ITFC+to+Implement+U.S.+%243+Billion+Framework+Agreements+through+two+new+Financing+Agreements+to+Support+Egypt%E2%80%99s+Main+Sectors"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/70778"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/itfc-to-implement-us-3-billion-framework-agreements-through-two-new-financing-agreements-to-support-egypts-main-sectors');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/agriculture">Agriculture</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                                                                                                                                                          </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="70686" data-pressPublished="2018-09-06T17:12:07Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                    <li><a href="https://itfc.africa-newsroom.com/press/media/league-of-arab-states-and-international-islamic-trade-finance-corporation-announce-cooperation-towards-intraarab-trade?lang=en&display=image"><i class="fa fa-picture-o"></i> Images <span>(1)</span></a>
                <ul>
                                        <li><i class="fa fa-caret-right"></i>League of Arab States and International Islamic Trade Finance Corporation announce cooperation towards intra-Arab trade</li>
                                    </ul>
            </li>
                                                <li><a href="https://itfc.africa-newsroom.com/press/media/league-of-arab-states-and-international-islamic-trade-finance-corporation-announce-cooperation-towards-intraarab-trade?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(1)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/70686/http%3A%7D%7Dwww.ITFC-IDB.org/website" target="_blank" rel="nofollow">
                    International Islamic Trade Fi...                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/league-of-arab-states-and-international-islamic-trade-finance-corporation-announce-cooperation-towards-intraarab-trade?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(2)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2018-09-06T17:12:07Z">
                    Sep 06, 2018                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/league-of-arab-states-and-international-islamic-trade-finance-corporation-announce-cooperation-towards-intraarab-trade?lang=en" title="League of Arab States and International Islamic Trade Finance Corporation announce cooperation towards intra-Arab trade">League of Arab States and International Islamic Trade Finance Corporation announce cooperation towards intra-Arab trade</a></h2>
                    <p class="home-subheading"><strong>The Memorandum of Understanding (MoU) outlines clear objectives aimed at enhancing trade capacities and improving structures and mechanisms of trade cooperation among Arab countries</strong></p>
        
        
        
        <p>The League of Arab States (Economic Affairs Sector) and the International Islamic Trade Finance Corporation (ITFC) (www.ITFC-IDB.org), a member of the Islamic Development Bank Group, have signed a Memorandum of Understanding (MoU) towards accelerating cooperation in the development of intra-Arab trade.





Signed during the Ministerial meeting of the Economic and&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/league-of-arab-states-and-international-islamic-trade-finance-corporation-announce-cooperation-towards-intraarab-trade?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="70686" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://goo.gl/ezZHtn"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="70686" title="twitter" href="https://twitter.com/intent/tweet?text=League+of+Arab+States+and+International+Islamic+Trade+Finance+Corporation+announce+cooperation+towards+intra-Arab+trade+https%3A%2F%2Fgoo.gl%2FezZHtn+%23bankingfinance+%23business">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="70686" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://goo.gl/ezZHtn&amp;title=League+of+Arab+States+and+International+Islamic+Trade+Finance+Corporation+announce+cooperation+towards+intra-Arab+trade&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="70686" title="google" href="https://plus.google.com/share?url=https://goo.gl/ezZHtn"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="70686" title="tumblr" href="https://www.tumblr.com/share/link?url=https://goo.gl/ezZHtn&amp;name=League+of+Arab+States+and+International+Islamic+Trade+Finance+Corporation+announce+cooperation+towards+intra-Arab+trade"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="70686" title="reddit" href="http://reddit.com/submit?url=https://goo.gl/ezZHtn&amp;title=League+of+Arab+States+and+International+Islamic+Trade+Finance+Corporation+announce+cooperation+towards+intra-Arab+trade"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="70686" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b23c1209ee72429/200/150&amp;url=https://goo.gl/ezZHtn&amp;description=League+of+Arab+States+and+International+Islamic+Trade+Finance+Corporation+announce+cooperation+towards+intra-Arab+trade"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="70686" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=https://goo.gl/ezZHtn&amp;title=League+of+Arab+States+and+International+Islamic+Trade+Finance+Corporation+announce+cooperation+towards+intra-Arab+trade"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/70686"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/league-of-arab-states-and-international-islamic-trade-finance-corporation-announce-cooperation-towards-intraarab-trade');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                  <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                                                                                                                                      </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>
  
<article class="row " data-pressid="68897" data-pressPublished="2018-08-09T07:28:33Z">
  <div class="col-lg-3 col-md-3 col-sm-4 col-xs-12">
    <figure>
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive listing-image" src="https://itfc.africa-newsroom.com/files/thumb/566148860c5ab3e/200/150" alt="International Islamic Trade Finance Corporation (ITFC)" title="See more news from this source">
        </a>
    </figure>
        <div class="media-content">
        <ul>
            <li><h4 class="media-title">Multimedia content</h4></li>
                                                            <li><a href="https://itfc.africa-newsroom.com/press/media/federated-investors-inc-and-international-islamic-trade-finance-corporation-to-develop-a-tradefinance-portfolio-focused-on-sovereign-energy-sector?lang=en&display=link"><i class="fa fa-link"></i> Links <span>(2)</span></a>
                <ul>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/68897/http%3A%7D%7Dwww.ITFC-IDB.org%7Den/website" target="_blank" rel="nofollow">
                    International Islamic Trade Fi...                    </a></li>
                                      <li><i class="fa fa-caret-right"></i><a href="/press/countlinks/68897/http%3A%7D%7Dwww.FederatedInvestors.com%7DFII%7Dhome.do/website" target="_blank" rel="nofollow">
                    Federated Investors, Inc. (NYS...                    </a></li>
                                  </ul>
            </li>
                        <li><a href="https://itfc.africa-newsroom.com/press/media/federated-investors-inc-and-international-islamic-trade-finance-corporation-to-develop-a-tradefinance-portfolio-focused-on-sovereign-energy-sector?lang=en&display=all"><i class="fa fa-angle-double-right"></i> All <span>(2)</span></a></li>
        </ul>
    </div>
      </div>
  <!-- /column 2 ends here -->
  <div class="col-lg-9 col-md-9 col-sm-8 col-xs-12">
    <div class="n-row-wrapper">
        <span class="source-time">
            Source: 
                <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
                <time class="timeago" datetime="2018-08-09T07:28:33Z">
                    Aug 09, 2018                </time>
                        </span>
                <h2 class="press_title"><a href="https://itfc.africa-newsroom.com/press/federated-investors-inc-and-international-islamic-trade-finance-corporation-to-develop-a-tradefinance-portfolio-focused-on-sovereign-energy-sector?lang=en" title="Federated Investors, Inc. and International Islamic Trade Finance Corporation to Develop a Trade-Finance Portfolio Focused on Sovereign Energy Sector">Federated Investors, Inc. and International Islamic Trade Finance Corporation to Develop a Trade-Finance Portfolio Focused on Sovereign Energy Sector</a></h2>
                    <p class="home-subheading"><strong>The portfolio will be Shari’ah compliant with investments realized through transaction structures that rigorously adhere to Islamic principles</strong></p>
        
        
        
        <p>Federated Investors, Inc. (NYSE: FII) (www.FederatedInvestors.com/FII/home.do), one of the largest investment managers in the United States, and the International Islamic Trade Finance Corporation (ITFC) (www.ITFC-IDB.org/en), member of the Islamic Development Bank (IsDB) Group, announced an agreement to launch a sovereign energy trade-finance portfolio.





The ITFC Sovereign Energy Fund (ISEF) will&#8230;</p>
      <footer>
        <div class="short-links">
          <ul class="q-links clearfix">
            <li><a href="https://itfc.africa-newsroom.com/press/federated-investors-inc-and-international-islamic-trade-finance-corporation-to-develop-a-tradefinance-portfolio-focused-on-sovereign-energy-sector?lang=en"><i class="fa fa-share"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:void(1);"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-id="" data-id="" data-pressid="68897" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://goo.gl/W8k9ib"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-id="" data-pressid="68897" title="twitter" href="https://twitter.com/intent/tweet?text=Federated+Investors%2C+Inc.+and+International+Islamic+Trade+Finance+Corporation+to+Develop+a+Trade-Finance+Portfolio+Focused+on+Sovereign+Energy+Sector+https%3A%2F%2Fgoo.gl%2FW8k9ib+%23bankingfinance+%23business+%23energy">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-id="" data-pressid="68897" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://goo.gl/W8k9ib&amp;title=Federated+Investors%2C+Inc.+and+International+Islamic+Trade+Finance+Corporation+to+Develop+a+Trade-Finance+Portfolio+Focused+on+Sovereign+Energy+Sector&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-id="" data-pressid="68897" title="google" href="https://plus.google.com/share?url=https://goo.gl/W8k9ib"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-id="" data-pressid="68897" title="tumblr" href="https://www.tumblr.com/share/link?url=https://goo.gl/W8k9ib&amp;name=Federated+Investors%2C+Inc.+and+International+Islamic+Trade+Finance+Corporation+to+Develop+a+Trade-Finance+Portfolio+Focused+on+Sovereign+Energy+Sector"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-id="" data-pressid="68897" title="reddit" href="http://reddit.com/submit?url=https://goo.gl/W8k9ib&amp;title=Federated+Investors%2C+Inc.+and+International+Islamic+Trade+Finance+Corporation+to+Develop+a+Trade-Finance+Portfolio+Focused+on+Sovereign+Energy+Sector"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-id="" data-pressid="68897" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/566148860c5ab3e/200/150&amp;url=https://goo.gl/W8k9ib&amp;description=Federated+Investors%2C+Inc.+and+International+Islamic+Trade+Finance+Corporation+to+Develop+a+Trade-Finance+Portfolio+Focused+on+Sovereign+Energy+Sector"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-id="" data-pressid="68897" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=https://goo.gl/W8k9ib&amp;title=Federated+Investors%2C+Inc.+and+International+Islamic+Trade+Finance+Corporation+to+Develop+a+Trade-Finance+Portfolio+Focused+on+Sovereign+Energy+Sector"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
              <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/68897"><i class="fa fa-star"></i> Favourite</a></li>
            <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/federated-investors-inc-and-international-islamic-trade-finance-corporation-to-develop-a-tradefinance-portfolio-focused-on-sovereign-energy-sector');"><i class="fa fa-print"></i> Print</a></li>
          </ul>
        </div>
        <div class="short-tags">
          <ul>
                                                                                            <li><a href="https://itfc.africa-newsroom.com/press/tag/bankingfinance">Banking/Finance</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/business">Business</a></li>
                                                      <li><a href="https://itfc.africa-newsroom.com/press/tag/energy">Energy</a></li>
                                                                                                                                            </ul>
        </div>
      </footer>
    </div>
  </div>
  <!-- /column 2 ends here -->
</article>

</div>
<div id="message"></div>
<div id="loading-gif" style="display:none;"><h3 class="text-center"><img width="16" height="11" alt="Loading.." src="https://itfc.africa-newsroom.com/addons/shared_addons/themes/apofront/img/loader.gif" /></h3></div>


    


        </div>
        <!-- /columns eight ends here -->
        <div class="sidebar-front hidden-xs hidden-sm" id="sidebar-front">
                            <aside role="complementary" class="aside-front">
  <div class="social-box">
      <div class="social-top">
      <a href="https://itfc.africa-newsroom.com/source?lang=en">
        <img src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f" alt="International Islamic Trade Finance Corporation (ITFC)" class="img-responsive pull-left" style="width:100px" />
        <h3>International Islamic Trade Finance Corporation (ITFC)</h3>      
        <p>
        The International Islamic Trade Finance Corporation is an autonomous entity within the Islamic Development Bank Group created with the purpose of advancing trade to improve the economic condition and livelihood of people across the Islamic world. ITFC has consolidated all the trade finance businesses&#8230;        </p>
        </a>
      </div>
      <a href="https://itfc.africa-newsroom.com/source" class="more">More information</a>      
      <div class="social-links clearfix"> 
        <ul class="social pull-right">
                <li><a href="https://www.Facebook.com/ITFCorp/" class="item1" target="_blank">Facebook</a></li>
                        <li><a href="https://Twitter.com/ITFC_IDB" class="item2" target="_blank">Twitter</a></li>
                        <li><a href="https://www.LinkedIn.com/company-beta/591328/" class="item3" target="_blank">LinkedIn</a></li>
                                                                      </ul>
      </div>
    </div>
      <!-- /newsletter box -->

  <div class="widget html ">
		<a href="https://itfc.africa-newsroom.com/africarc">
<div id="sidebarrssfeed">
<div class="bgcontent">Subscribe<br><small>EMAIL, RSS, FTP AND MORE</small></div>
 </div>
 </a></div>

<div class="widget html ">
		<a href="https://itfc.africa-newsroom.com/source#media-kit">
<div id="sidebarsubscribe">
<div class="bgcontent">Media kit<br><small>Download media kit</small></div>
 </div>
 </a></div>

<div class="widget press_most_viewed ">
		<div class="news-slider box ltr">
<h4>Most viewed</h4>
<ul class="bx-slider ltr">
      <li class="clearfix">
    <div class="news-wrap">
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive" src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/300/200" alt="International Islamic Trade Finance Corporation recognized as Best Islamic Financier at the International Trade Finance Global (TFG) Trade Awards 2020" />
        </a>
        
                <small>Source: <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
            <em><time class="timeago" datetime="2020-03-23T10:23:40Z">Mar 23, 2020</time></em>
        </small>
        <strong><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020?lang=en">International Islamic Trade Finance Corporation recognized as Best Islamic Financier at the International Trade Finance Global (TFG) Trade Awards 2020</a></strong>
      <p>The winners were selected by an independent steering committee of industry experts from around the world</p>

      <footer>
        <ul class="q-links clearfix">
          <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020?lang=en"><i class="fa fa-angle-double-right"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:;"><i class="fa fa-share-alt"></i> Share</a>
              <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-pressid="107166" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=https://bit.ly/2J4XxBs
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-pressid="107166" title="twitter" href="https://twitter.com/intent/tweet?text=+https%3A%2F%2Fbit.ly%2F2J4XxBs%0A%40ITFCCORP">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-pressid="107166" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://bit.ly/2J4XxBs
&amp;title=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-pressid="107166" title="google" href="https://plus.google.com/share?url=https://bit.ly/2J4XxBs
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-pressid="107166" title="tumblr" href="https://www.tumblr.com/share/link?url=https://bit.ly/2J4XxBs
&amp;name=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-pressid="107166" title="reddit" href="http://reddit.com/submit?url=https://bit.ly/2J4XxBs
&amp;title=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-pressid="107166" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/300/200&amp;url=https://bit.ly/2J4XxBs
&amp;description=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-pressid="107166" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=https://bit.ly/2J4XxBs
&amp;title=International+Islamic+Trade+Finance+Corporation+recognized+as+Best+Islamic+Financier+at+the+International+Trade+Finance+Global+%28TFG%29+Trade+Awards+2020"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
                            <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/107166"><i class="fa fa-star"></i> Favourite</a></li>
                        <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-recognized-as-best-islamic-financier-at-the-international-trade-finance-global-tfg-trade-awards-2020');"><i class="fa fa-print"></i> Print</a></li>
        </ul>
      </footer>
    </div>
  </li>
  <li class="clearfix">
    <div class="news-wrap">
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive" src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/300/200" alt="International Islamic Trade Finance Corporation (ITFC) Ranks 2nd Globally and as well in Europe, Middle East and Africa (EMEA) as Islamic Finance Bookrunner and Mandated Lead Arranger - Bloomberg Syndicated Loans League Tables 2019" />
        </a>
        
                <small>Source: <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
            <em><time class="timeago" datetime="2020-03-16T09:33:31Z">Mar 16, 2020</time></em>
        </small>
        <strong><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en">International Islamic Trade Finance Corporation (ITFC) Ranks 2nd Globally and as well in Europe, Middle East and Africa (EMEA) as Islamic Finance Bookrunner and Mandated Lead Arranger - Bloomberg Syndicated Loans League Tables 2019</a></strong>
      <p>The League Tables, showed that the ITFC provided financing worth in excess of US$2 billion as Bookrunner and Mandated Lead Arranger in 2019</p>

      <footer>
        <ul class="q-links clearfix">
          <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en"><i class="fa fa-angle-double-right"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:;"><i class="fa fa-share-alt"></i> Share</a>
              <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-pressid="106586" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/39PWYqO
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-pressid="106586" title="twitter" href="https://twitter.com/intent/tweet?text=+http%3A%2F%2Fbit.ly%2F39PWYqO%0A%40ITFCCORP">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-pressid="106586" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-pressid="106586" title="google" href="https://plus.google.com/share?url=http://bit.ly/39PWYqO
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-pressid="106586" title="tumblr" href="https://www.tumblr.com/share/link?url=http://bit.ly/39PWYqO
&amp;name=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-pressid="106586" title="reddit" href="http://reddit.com/submit?url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-pressid="106586" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/300/200&amp;url=http://bit.ly/39PWYqO
&amp;description=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-pressid="106586" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
                            <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/106586"><i class="fa fa-star"></i> Favourite</a></li>
                        <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019');"><i class="fa fa-print"></i> Print</a></li>
        </ul>
      </footer>
    </div>
  </li>
</ul>
</div>
</div>

<div class="widget press_most_shared ">
		<div class="news-slider box ltr">
<h4>Most shared</h4>
<ul class="bx-slider ltr">
      <li class="clearfix">
    <div class="news-wrap">
        <a href="https://itfc.africa-newsroom.com">
            
            <img class="img-responsive" src="https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/300/200" alt="International Islamic Trade Finance Corporation (ITFC) Ranks 2nd Globally and as well in Europe, Middle East and Africa (EMEA) as Islamic Finance Bookrunner and Mandated Lead Arranger - Bloomberg Syndicated Loans League Tables 2019" />
        </a>

                <small>Source: <a href="https://itfc.africa-newsroom.com">International Islamic Trade Finance Corporation (ITFC)</a> | 
            <em><time class="timeago" datetime="2020-03-16T09:33:31Z">Mar 16, 2020</time></em>
        </small>
        <strong><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en">International Islamic Trade Finance Corporation (ITFC) Ranks 2nd Globally and as well in Europe, Middle East and Africa (EMEA) as Islamic Finance Bookrunner and Mandated Lead Arranger - Bloomberg Syndicated Loans League Tables 2019</a></strong>
      <p>The League Tables, showed that the ITFC provided financing worth in excess of US$2 billion as Bookrunner and Mandated Lead Arranger in 2019</p>

      <footer>
        <ul class="q-links clearfix">
          <li><a href="https://itfc.africa-newsroom.com/press/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019?lang=en"><i class="fa fa-angle-double-right"></i> Read more</a></li>
            <li class="social-share"><a href="javascript:;"><i class="fa fa-share-alt"></i> Share</a>
                <ul class="icns social-list">
                                        <li><a target="_blank" data-social="f" data-type="p" data-pressid="106586" title="facebook" href="https://www.facebook.com/sharer/sharer.php?u=http://bit.ly/39PWYqO
"><i class="fa fa-facebook"></i></a></li>
                    <li><a target="_blank" data-social="t" data-type="p" data-pressid="106586" title="twitter" href="https://twitter.com/intent/tweet?text=+http%3A%2F%2Fbit.ly%2F39PWYqO%0A%40ITFCCORP">
                    <i class="fa fa-twitter"></i></a></li>
                    <li><a target="_blank" data-social="l" data-type="p" data-pressid="106586" title="linkedin" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019&amp;source=APO+Group+-+Africa+Newsroom"><i class="fa fa-linkedin"></i></a></li>
                    <li><a target="_blank" data-social="g" data-type="p" data-pressid="106586" title="google" href="https://plus.google.com/share?url=http://bit.ly/39PWYqO
"><i class="fa fa-google-plus"></i></a></li>
                    <li><a target="_blank" data-social="tu" data-type="p" data-pressid="106586" title="tumblr" href="https://www.tumblr.com/share/link?url=http://bit.ly/39PWYqO
&amp;name=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-tumblr"></i></a></li>
                    <li><a target="_blank" data-social="r" data-type="p" data-pressid="106586" title="reddit" href="http://reddit.com/submit?url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-reddit"></i></a></li>
                    <li><a target="_blank" data-social="p" data-type="p" data-pressid="106586" title="pinterest" href="https://pinterest.com/pin/create/bookmarklet/?media=https://itfc.africa-newsroom.com/files/thumb/b0d19d1647cfc6f/300/200&amp;url=http://bit.ly/39PWYqO
&amp;description=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-pinterest"></i></a></li>
                    <li><a target="_blank" data-social="s" data-type="p" data-pressid="106586" title="stumpleupon" href="http://www.stumbleupon.com/submit?url=http://bit.ly/39PWYqO
&amp;title=International+Islamic+Trade+Finance+Corporation+%28ITFC%29+Ranks+2nd+Globally+and+as+well+in+Europe%2C+Middle+East+and+Africa+%28EMEA%29+as+Islamic+Finance+Bookrunner+and+Mandated+Lead+Arranger+-+Bloomberg+Syndicated+Loans+League+Tables+2019"><i class="fa fa-stumbleupon"></i></a></li>
                </ul>
            </li>
                            <li><a href="https://itfc.africa-newsroom.com/access/press/favorite/add/106586"><i class="fa fa-star"></i> Favourite</a></li>
                        <li><a href="javascript:print_view('https://itfc.africa-newsroom.com/press/printview/international-islamic-trade-finance-corporation-itfc-ranks-2nd-globally-and-as-well-in-europe-middle-east-and-africa-emea-as-islamic-finance-bookrunner-and-mandated-lead-arranger-bloomberg-syndicated-loans-league-tables-2019');"><i class="fa fa-print"></i> Print</a></li>
        </ul>
      </footer>
    </div>
  </li>
</ul>
</div>
</div>


<div class="widget html ">
		<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div class="fb-page" data-width="320" data-href="https://www.facebook.com/ITFCorp/" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/ITFCorp/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/ITFCorp/">International Islamic Trade Finance Corporation - ITFC</a></blockquote></div></div>


<div class="widget html ">
		<script src="//platform.linkedin.com/in.js" type="text/javascript"></script>
<script type="IN/CompanyProfile" data-id="591328" data-format="inline" data-width="320"></script></div>




</aside>

                    </div>
        <!-- sidebar ends here -->
      </div>
    </div>
    </div>
    <!-- content ends here -->
            	<!-- content ends here -->
	</div>
  <footer class="footer clearfix">
    <div class="container">
        <!-- <div class="row">
            <div class="col-lg-6 col-md-6 col-sm-6 col-xs-12">
              <p>2020 International Islamic Trade Finance Corporation (ITFC)</p>
            </div>
            <div class="col-lg-6 col-md-6 col-sm-6 col-xs-12">
            </div>
          </div>
          </div> -->
      </footer>
    <a href="#" id="toTop" style="display: block;"><i class="fa fa-chevron-up"></i><span id="toTopHover" style="opacity: 1;"></span></a>
<div class="modal fade" id="modal-login">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                    <h4 class="modal-title">Login</h4>
                </div>
                <div class="modal-social-signup">
                    <div class="clearfix">
                        <a class="facebook-signup" href="https://itfc.africa-newsroom.com/social/session/facebook">
                            <img alt="facebook-signup" src="https://itfc.africa-newsroom.com/addons/shared_addons/themes/apofront/img/facebook-signup.png" />
                        </a>
                        <a class="twitter-signup" href="https://itfc.africa-newsroom.com/social/session/twitter">
                            <img alt="twitter-signup" src="https://itfc.africa-newsroom.com/addons/shared_addons/themes/apofront/img/twitter-signup.png" />
                        </a>
                    </div>
                    <div class="clearfix divider">
                        <p>OR</p>
                    </div>
                </div>
                <div class="modal-body">
                <div id="login-messages">
                    <div></div>
                </div>
                <form action="https://africa-newsroom.com/users/login" role="form" id="modal-login-form" method="post" accept-charset="utf-8">
                    <div class="form-group">
                    <input type="text" name="email" value="" class="form-control input-sm" placeholder="Username" />
                    </div>
                    <div class="form-group">
                    <input class="form-control input-sm" type="password" id="password" name="password" maxlength="20" placeholder='Password' />
                    </div>
                    <div class="form-group">
                    <div class="row">
                      <div class="col-lg-8 col-md-8 col-sm-8 col-xs-12">
                                <p class="frgt-pass"><a href="https://itfc.africa-newsroom.com/users/reset_pass">Forgot your password?</a><a href="https://itfc.africa-newsroom.com/register" id="noaccount">Don’t have an account? Sign up here</a>
                                </p>
                            </div>
                            <div class="col-lg-4 col-md-4 col-sm-4 col-xs-12 ">
                                <button id="login-button" type="submit" class="btn btn-primary btn-lg pull-right">Login</button>
                            </div>
                        </div>
                    </div>


                    </form>
                </div>
            </div>
            <!-- /.modal-content -->
        </div>
        <!-- /.modal-dialog -->
    </div>
    <!-- /.modal -->

    <!-- Scripts -->
    


	









    
    




<script src="https://itfc.africa-newsroom.com/assets/cache/406ef444693f24cdd221e255cde61a62.js"></script>

<script>

    $(document).on('click','.copy-embed',function(){
        $(this).closest('.multimedia-video').find('input.copy_embed_text').toggle('slow');
        $(this).closest('.multimedia-video').find('input.copy_embed_text').select();
    })

    $('input.copy_embed_text').click(function(){
    $(this).select();
    })

    $( document ).ready(function() {
        var outer_width = jQuery('.live-video-item').outerWidth();

        var iframe_height = outer_width/1.77;

        $('.live-video-item').height(iframe_height);
    });
    

</script>
<script>

    //declaring variables
    var search_filter = '{"press_source_id":["713"],"per_page":"10","uri_segment":3,"press_status":1,"lang":"en","offset":10,"data_source":"solr"}';
    var postData = $.parseJSON(search_filter);
    $('#infinite-scroll').infinitus({
        trigger : function(done) {
            // The object that reached the bottom edge of the page is available via $(this)
            var obj = $(this);
            // Get the next batch of content you want to add to your element
            //var search_form_data = $('form[name="press_search"]').serialize();
            $.ajax({
                url: 'https://itfc.africa-newsroom.com/press/ajax_press',
                data: postData,
                type: 'post',
                async: true,
                dataType: 'html',
                success: function(data) {
                    // var infiniteWidth = $("div.main-container").width();
                    if (data) {
                        obj.append(data);
                        // $("#infinite-scroll").css('width', infiniteWidth);
                        postData.offset = +postData.offset + +postData.per_page;
                        //console.log(postData);
                        $("time.timeago").timeago();
                        done();
                    } else {
                        $("#loading-gif").hide();
                        $("#message").addClass('alert alert-success');
                        $("#message").html("No more press releases to load. <a href='https://appablog.wordpress.com' target='_blank'>Access to APO Group archives</a>");
                    }
                }
            });
        },
        onStart : function() {
            // Show something entertaining
            $("#loading-gif").show();
        },
        onEnd : function() {
            $("#loading-gif").hide();
            //sidebar here
            var $sidebar = $("#sidebar-front");
            $.ajax({
                url: 'https://itfc.africa-newsroom.com/press/ajax_sidebar',
                data: {},
                type: 'post',
                async: true,
                dataType: 'json',
                success: function(data) {
                    if (data.aside) {
                        $sidebar.append(data.aside);
                        apo.newsSlider('.loaded-sidebar.'+data.datetime+' .bx-slider');
                        //apo.newsSlider();
                    }
                }
            });
        }
    });

    $(function(){
        setInterval(function()
        {
            postData.last_press_id = $("#infinite-scroll > article:first-child").data('pressid');
            $.ajax({
                url: 'https://itfc.africa-newsroom.com/press/ajax_recent_press',
                data: postData,
                type: 'post',
                async: true,
                dataType: 'json',
                success: function(data) {
                    if (data.count > 0) {
                        $("#infinite-scroll").prepend(data.html);
                        postData.offset = +postData.offset + +data.count;
                        $("time.timeago").timeago();
                    }
                }
            });
        }, 1000 * 60 * 5);
    });

</script>
<script>

	$(document).ready(function() {
		var defaults = {
  			containerID: 'toTop', // fading element id
			containerHoverID: 'toTopHover', // fading element hover id
			scrollSpeed: 1200,
			easingType: 'linear' 
 		};
		if (jQuery.isFunction(jQuery.fn.UItoTop)) {
			$().UItoTop({ easingType: 'easeOutQuart' });
		}
	});

</script>
<script>

    /*var engine = new Bloodhound({
      datumTokenizer: Bloodhound.tokenizers.obj.whitespace('value'),
      queryTokenizer: Bloodhound.tokenizers.whitespace,
      //prefetch: '../data/films/post_1960.json',
      remote: "https://itfc.africa-newsroom.com/press/ajax_autocomplete?query=%QUERY"
    });
    engine.initialize();
    var initTypeahead = function(selector){
        var initialVal = "";
        var currentVal = $("input#keyword").val();
        $(selector).typeahead(null, {
            //name: 'keyword',
            minLength: 5,
            highlight: true,
            hint: false,
            displayKey: 'value',
            source: engine.ttAdapter(),
        });
    }*/

    $(function(){
        //initTypeahead('#keyword');
        $('.advance-search').show();
    });

    //press note rotator
    $(function ($) {
        setInterval(function () {
            $(".copyright-message > span").slideToggle(1000);
        }, 5000)

        $('select.has-items').next().find('button').addClass('active');
    });

    //media type filter
    function showHideMediaFilter(press_type)
    {
        if(press_type == 'media'){
            $(".checkbox.media_types").show();
        }
        else{
            $(".checkbox.media_types").hide();
        }
    }
    //get press type on load
    var press_type = $('input:radio[name="press_type"]:checked').val();
    showHideMediaFilter(press_type);
    //get press type on click
    $('input:radio[name="press_type"]').on('click', function(){
        var press_type = $(this).val();
        showHideMediaFilter(press_type);
    });
    var media_filter_all = $('.mediatype-checkall:checked').data('value');
    if(media_filter_all){
        $('.mediatype-check').prop("checked", true);
    }
    $('.mediatype-checkall').on('click', function(){
        var is_checked = $(this).is(':checked');
        if(is_checked){
            $('.mediatype-check').prop("checked", true);
        }
        else{
            $('.mediatype-check').prop("checked", false);
        }
    });

    $('.mediatype-check').on('click', function(){
        var total = $('.mediatype-check').length;
        var checked = $('.mediatype-check:checked').length;
        if(total == checked){
            $('.mediatype-checkall').prop("checked", true);
        }
        else{
            $('.mediatype-checkall').prop("checked", false);
        }
    });

</script>
<script>

    // Multilingual Support for BX Slider - anunay
    var nextLabel = "Next";
    var prevLabel = "Previous";
    $(function(){
                
        $('.error').parent('div').addClass('has-error');
        $('.error').hide();

        var loginFields = {'username' : "Username *", 
            'password' : 'Password *'
            };

            $.each(loginFields, function(i,v){
            $("input."+i).addClass('form-control'); 
            $("input."+i).attr('placeholder', v); 
        });

        //lets validate
        if ($.isFunction(jQuery.fn.bootstrapValidator)) 
        {
            $('#modal-login-form').bootstrapValidator({
                excluded: ':disabled',
                message: 'This value is not valid',
                feedbackIcons: {
                    valid: 'glyphicon glyphicon-ok',
                    invalid: 'glyphicon glyphicon-remove',
                    validating: 'glyphicon glyphicon-refresh'
                },
                fields: {
                    email: {
                        validators: {
                            notEmpty: {
                                message: "The " + loginFields.username + " field is required."
                            }
                        }
                    },
                    password: {
                        validators: {
                            notEmpty: {
                                message: "The " + loginFields.password + " field is required."
                            },
                            stringLength: {
                                min: 6,
                                max: 30,
                                message: ""
                            },
                        }
                    },                
                    
                }
            });
        }
        $('.add-control-css input[type="text"], .add-control-css textarea, .add-control-css select').addClass('form-control input-sm');
    });

</script>

  <!-- End Scripts -->

    <!-- footer ends here -->
      </body>
</html>
